Login
DevelopersDocumentationDownloadBuy
DEi
Launching IDE
  1. Goto your Dashboard
  2. Select a project from the list
  3. Click on Launch IDE
  4. IDE will be opened in a new window
IDE
Menu Bar
  • File Menu -
  • Insert Menu - Insert new buttons, sliders etc.
  • Help Menu - Access Guide at any time
  • Save - Save your progress
  • Build - Compile your project
  • Run - Deploy your project in your mobile
  • Project Explorer
    Your project contain a main file
  • Your_Project.ino
  • The '.ino file' contain the sketch that you need to burn into your microprocessor board.
    Working Modes

    Virtual Mode
    In Virtual Mode, You are coding your entire sketch in D.Ei. Your Board contain only the D.Ei Engine Code snippet.

    Use Virtual Mode if your creating a controller for public use.

    Board Mode
    Board Mode works in normal way. D.Ei send the data about active button state, motion sensed, speech detected to the board. All other operations you need to burn into your board using the boards IDE.

    Learn more about Working Modes
    Plugins
    Plugins are additional features for easy communication between your phone and device.
  • Speech - Enables speech commands.
  • Motion - Let the motion of your phone control your device.
  • Sense - Run commands on swipe, tap, pinch.
  • Text Input - Enter commands directly through text input box.

  • Learn more about Plugins
    Preview your project
  • Arrange the positions of buttons & sliders.